const regex = /\[Vidible.*?vids=\"(.*?)\".*?\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[Vidible.*?vids=\\"(.*?)\\".*?\\]', 'g')
const str = `Plugin test.\\r\\n\\r\\n[Vidible pid="540733fae4b061fe2c0e6532" bcid="538612f0e4b00fbb8e898655" vids="5407208be4b0e541a65ce855,53e1cd2ce4b07ee7365f29d1,53fc8bcde4b0bbef08f3bfbd"]\\r\\n\\r\\nMore text.x[Vidible pid="540733fae4b061fe2c0e6532" bcid="538612f0e4b00fbb8e898655" vids="5407208be4b0e541a65ce855,53e1cd2ce4b07ee7365f29d1,53fc8bcde4b0bbef08f3bfbd"]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}