$re = '/\[Vidible.*?vids=\"(.*?)\".*?\]/';
$str = 'Plugin test.\\r\\n\\r\\n[Vidible pid="540733fae4b061fe2c0e6532" bcid="538612f0e4b00fbb8e898655" vids="5407208be4b0e541a65ce855,53e1cd2ce4b07ee7365f29d1,53fc8bcde4b0bbef08f3bfbd"]\\r\\n\\r\\nMore text.x[Vidible pid="540733fae4b061fe2c0e6532" bcid="538612f0e4b00fbb8e898655" vids="5407208be4b0e541a65ce855,53e1cd2ce4b07ee7365f29d1,53fc8bcde4b0bbef08f3bfbd"]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);