#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d*,[^,]*,\d*,(?:true|false)\|?)+(?<!\|)$"
Local $sString = "253,RFTL 9984.0,588,false|545,kajfkaj,988,true" & @CRLF & _
"253,RFTL 9984.0,588,false||545,kajfkaj,988,true" & @CRLF & _
"253,RFTL 9984.0,588,false|545,kajfkaj,988,true|" & @CRLF & _
"253,RFTL 9984.0,588,false|545,kajfkaj,988,true|545,kajfkaj,988,true"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")