$re = '/^(?:\d*,[^,]*,\d*,(?:true|false)\|?)+(?<!\|)$/m';
$str = '253,RFTL 9984.0,588,false|545,kajfkaj,988,true
253,RFTL 9984.0,588,false||545,kajfkaj,988,true
253,RFTL 9984.0,588,false|545,kajfkaj,988,true|
253,RFTL 9984.0,588,false|545,kajfkaj,988,true|545,kajfkaj,988,true';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);