import re
regex = re.compile(r"^(?:\d*,[^,]*,\d*,(?:true|false)\|?)+(?<!\|)$", flags=re.MULTILINE)
test_str = ("253,RFTL 9984.0,588,false|545,kajfkaj,988,true\n"
"253,RFTL 9984.0,588,false||545,kajfkaj,988,true\n"
"253,RFTL 9984.0,588,false|545,kajfkaj,988,true|\n"
"253,RFTL 9984.0,588,false|545,kajfkaj,988,true|545,kajfkaj,988,true")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")