using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\d*,[^,]*,\d*,(?:true|false)\|?)+(?<!\|)$";
string input = @"253,RFTL 9984.0,588,false|545,kajfkaj,988,true
253,RFTL 9984.0,588,false||545,kajfkaj,988,true
253,RFTL 9984.0,588,false|545,kajfkaj,988,true|
253,RFTL 9984.0,588,false|545,kajfkaj,988,true|545,kajfkaj,988,true";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}