import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d*,[^,]*,\\d*,(?:true|false)\\|?)+(?<!\\|)$";
final String string = "253,RFTL 9984.0,588,false|545,kajfkaj,988,true\n"
+ "253,RFTL 9984.0,588,false||545,kajfkaj,988,true\n"
+ "253,RFTL 9984.0,588,false|545,kajfkaj,988,true|\n"
+ "253,RFTL 9984.0,588,false|545,kajfkaj,988,true|545,kajfkaj,988,true";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}