#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "s<.*>"
Local $sString = "<start>" & @CRLF & _
" <title> ." & @CRLF & _
" <Jamie-does-something-normal>" & @CRLF & _
" <Jamie-gets-mission>" & @CRLF & _
" <Mission-interruption> <Jamie-gets-in-terrible-bind>" & @CRLF & _
" <golly-gee> <Jamie-saves-the-day> " & @CRLF & _
" <transition> <Jamie-does-something-normal>" & @CRLF & _
" ;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")