// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"s<.*>").unwrap();
let string = "<start>
<title> .
<Jamie-does-something-normal>
<Jamie-gets-mission>
<Mission-interruption> <Jamie-gets-in-terrible-bind>
<golly-gee> <Jamie-saves-the-day>
<transition> <Jamie-does-something-normal>
;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}