$re = '/s<.*>/';
$str = '<start>
<title> .
<Jamie-does-something-normal>
<Jamie-gets-mission>
<Mission-interruption> <Jamie-gets-in-terrible-bind>
<golly-gee> <Jamie-saves-the-day>
<transition> <Jamie-does-something-normal>
;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);