using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"s<.*>";
string input = @"<start>
<title> .
<Jamie-does-something-normal>
<Jamie-gets-mission>
<Mission-interruption> <Jamie-gets-in-terrible-bind>
<golly-gee> <Jamie-saves-the-day>
<transition> <Jamie-does-something-normal>
;";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}