re = /s<.*>/
str = '<start>
<title> .
<Jamie-does-something-normal>
<Jamie-gets-mission>
<Mission-interruption> <Jamie-gets-in-terrible-bind>
<golly-gee> <Jamie-saves-the-day>
<transition> <Jamie-does-something-normal>
;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end