import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "s<.*>";
final String string = "<start>\n"
+ " <title> .\n"
+ " <Jamie-does-something-normal>\n"
+ " <Jamie-gets-mission>\n"
+ " <Mission-interruption> <Jamie-gets-in-terrible-bind>\n"
+ " <golly-gee> <Jamie-saves-the-day> \n"
+ " <transition> <Jamie-does-something-normal>\n"
+ " ;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}