#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b((?:[a-z]+\S*\d+|\d\S*[a-z]+)[a-z\d_-]*)\b"
Local $sString = "Foo text ADY123 bar" & @CRLF & _
"foo AD12ADY baz" & @CRLF & _
"bak 1HGER_2 bam baz 128D foo" & @CRLF & _
"lorem ipsum 128878P foo bar" & @CRLF & _
"again more text 145-DE-FR2 lol foo bar" & @CRLF & _
"this is not even matched BICYCLE lel" & @CRLF & _
"not this one either 183-329-193 cool" & @CRLF & _
"wow 3123123 not this either!" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")