import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((?:[a-z]+\\S*\\d+|\\d\\S*[a-z]+)[a-z\\d_-]*)\\b";
final String string = "Foo text ADY123 bar\n"
+ "foo AD12ADY baz\n"
+ "bak 1HGER_2 bam baz 128D foo\n"
+ "lorem ipsum 128878P foo bar\n"
+ "again more text 145-DE-FR2 lol foo bar\n"
+ "this is not even matched BICYCLE lel\n"
+ "not this one either 183-329-193 cool\n"
+ "wow 3123123 not this either!\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}