$re = '/\b((?:[a-z]+\S*\d+|\d\S*[a-z]+)[a-z\d_-]*)\b/i';
$str = 'Foo text ADY123 bar
foo AD12ADY baz
bak 1HGER_2 bam baz 128D foo
lorem ipsum 128878P foo bar
again more text 145-DE-FR2 lol foo bar
this is not even matched BICYCLE lel
not this one either 183-329-193 cool
wow 3123123 not this either!
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);