using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b((?:[a-z]+\S*\d+|\d\S*[a-z]+)[a-z\d_-]*)\b";
string input = @"Foo text ADY123 bar
foo AD12ADY baz
bak 1HGER_2 bam baz 128D foo
lorem ipsum 128878P foo bar
again more text 145-DE-FR2 lol foo bar
this is not even matched BICYCLE lel
not this one either 183-329-193 cool
wow 3123123 not this either!
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}