// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\b((?:[a-z]+\S*\d+|\d\S*[a-z]+)[a-z\d_-]*)\b").unwrap();
let string = "Foo text ADY123 bar
foo AD12ADY baz
bak 1HGER_2 bam baz 128D foo
lorem ipsum 128878P foo bar
again more text 145-DE-FR2 lol foo bar
this is not even matched BICYCLE lel
not this one either 183-329-193 cool
wow 3123123 not this either!
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}