#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:07:30|(0[8-9]|1[0-6]):[03]0)$"
Local $sString = "07:00" & @CRLF & _
"07:30" & @CRLF & _
"10:00" & @CRLF & _
"16:30" & @CRLF & _
"17:00" & @CRLF & _
"010:00" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")