re = /^(?:07:30|(0[8-9]|1[0-6]):[03]0)$/m
str = '07:00
07:30
10:00
16:30
17:00
010:00
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end