package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:07:30|(0[8-9]|1[0-6]):[03]0)$`)
var str = `07:00
07:30
10:00
16:30
17:00
010:00
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}