const regex = /^(?:07:30|(0[8-9]|1[0-6]):[03]0)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:07:30|(0[8-9]|1[0-6]):[03]0)$', 'gm')
const str = `07:00
07:30
10:00
16:30
17:00
010:00
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}