$re = '/^(?:07:30|(0[8-9]|1[0-6]):[03]0)$/m';
$str = '07:00
07:30
10:00
16:30
17:00
010:00
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);