// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:07:30|(0[8-9]|1[0-6]):[03]0)$").unwrap();
let string = "07:00
07:30
10:00
16:30
17:00
010:00
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}