#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?s).*\b\K[0-9]+/[0-9]+/[0-9]+"
Local $sString = "Some Text here" & @CRLF & _
"01/02/15" & @CRLF & _
"Some additional" & @CRLF & _
"text here." & @CRLF & _
"10/04/14" & @CRLF & _
"Ending text" & @CRLF & _
"here"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")