const regex = new RegExp('^(?s).*\\b\\K[0-9]+/[0-9]+/[0-9]+', 'gm')
const str = `Some Text here
01/02/15
Some additional
text here.
10/04/14
Ending text
here`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}