import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?s).*\\b\\K[0-9]+/[0-9]+/[0-9]+";
final String string = "Some Text here\n"
+ "01/02/15\n"
+ "Some additional\n"
+ "text here.\n"
+ "10/04/14\n"
+ "Ending text\n"
+ "here";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}