re = /^(?s).*\b\K[0-9]+\/[0-9]+\/[0-9]+/m
str = 'Some Text here
01/02/15
Some additional
text here.
10/04/14
Ending text
here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end