using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?s).*\b\K[0-9]+/[0-9]+/[0-9]+";
string input = @"Some Text here
01/02/15
Some additional
text here.
10/04/14
Ending text
here";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}