$re = '`^(?s).*\b\K[0-9]+/[0-9]+/[0-9]+`m';
$str = 'Some Text here
01/02/15
Some additional
text here.
10/04/14
Ending text
here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);