# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.(?![^.]+$)|[^0-9.]//g;t' <<< "£63.000.00"