$re = '/\.(?![^.]+$)|[^0-9.]/';
$str = '£63.000.00';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;