using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(?![^.]+$)|[^0-9.]";
string substitution = @"";
string input = @"£63.000.00";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}