use strict;
my $str = '£63.000.00';
my $regex = qr/\.(?![^.]+$)|[^0-9.]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";