import Foundation
let pattern = #"\.(?![^.]+$)|[^0-9.]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"£63.000.00"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)