using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<major>\d+).(?<minor>\d+).(?<patch>\d+)";
string input = @"[package]
name = ""regop""
version = ""0.2.0""
edition = ""2021""
repository = ""https://github.com/gbbirkisson/regop""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}