package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<major>\d+).(?<minor>\d+).(?<patch>\d+)`)
var str = `[package]
name = "regop"
version = "0.2.0"
edition = "2021"
repository = "https://github.com/gbbirkisson/regop"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}