const regex = new RegExp('(?<major>\\d+).(?<minor>\\d+).(?<patch>\\d+)', 'gm')
const str = `[package]
name = "regop"
version = "0.2.0"
edition = "2021"
repository = "https://github.com/gbbirkisson/regop"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}