$re = '/(?<major>\d+).(?<minor>\d+).(?<patch>\d+)/m';
$str = '[package]
name = "regop"
version = "0.2.0"
edition = "2021"
repository = "https://github.com/gbbirkisson/regop"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);