import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<major>\\d+).(?<minor>\\d+).(?<patch>\\d+)";
final String string = "[package]\n"
+ "name = \"regop\"\n"
+ "version = \"0.2.0\"\n"
+ "edition = \"2021\"\n"
+ "repository = \"https://github.com/gbbirkisson/regop\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}