// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<major>\d+).(?<minor>\d+).(?<patch>\d+)").unwrap();
let string = "[package]
name = \"regop\"
version = \"0.2.0\"
edition = \"2021\"
repository = \"https://github.com/gbbirkisson/regop\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}