#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w+@(?!gmail|hotmail|yahoo)\w+(?:-\w+)?\.[A-Za-z]{2,4}"
Local $sString = "Is there any validation in javascript or ruby on rails to allow user registration via corporate email" & @CRLF & _
"" & @CRLF & _
"for example of corporate email:- " & @CRLF & _
"1) jai@jai.com where jai is domain name " & @CRLF & _
"2) ajay@google.com where google.com is domain name" & @CRLF & _
"and not allow other email service email" & @CRLF & _
"" & @CRLF & _
"example :-" & @CRLF & _
"1) jai@gmail.com" & @CRLF & _
"2) jai@hotmail.com" & @CRLF & _
"3) jai@yahoo.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")