import Foundation
let pattern = #"\w+@(?!gmail|hotmail|yahoo)\w+(?:-\w+)?\.[A-Za-z]{2,4}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Is there any validation in javascript or ruby on rails to allow user registration via corporate email
for example of corporate email:-
1) jai@jai.com where jai is domain name
2) ajay@google.com where google.com is domain name
and not allow other email service email
example :-
1) jai@gmail.com
2) jai@hotmail.com
3) jai@yahoo.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)