use strict;
my $str = 'Is there any validation in javascript or ruby on rails to allow user registration via corporate email
for example of corporate email:-
1) jai@jai.com where jai is domain name
2) ajay@google.com where google.com is domain name
and not allow other email service email
example :-
1) jai@gmail.com
2) jai@hotmail.com
3) jai@yahoo.com';
my $regex = qr/\w+@(?!gmail|hotmail|yahoo)\w+(?:-\w+)?\.[A-Za-z]{2,4}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}