import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+@(?!gmail|hotmail|yahoo)\\w+(?:-\\w+)?\\.[A-Za-z]{2,4}";
final String string = "Is there any validation in javascript or ruby on rails to allow user registration via corporate email\n\n"
+ "for example of corporate email:- \n"
+ "1) jai@jai.com where jai is domain name \n"
+ "2) ajay@google.com where google.com is domain name\n"
+ "and not allow other email service email\n\n"
+ "example :-\n"
+ "1) jai@gmail.com\n"
+ "2) jai@hotmail.com\n"
+ "3) jai@yahoo.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}