$re = '/\w+@(?!gmail|hotmail|yahoo)\w+(?:-\w+)?\.[A-Za-z]{2,4}/';
$str = 'Is there any validation in javascript or ruby on rails to allow user registration via corporate email
for example of corporate email:-
1) jai@jai.com where jai is domain name
2) ajay@google.com where google.com is domain name
and not allow other email service email
example :-
1) jai@gmail.com
2) jai@hotmail.com
3) jai@yahoo.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);