import re
regex = re.compile(r"\w+@(?!gmail|hotmail|yahoo)\w+(?:-\w+)?\.[A-Za-z]{2,4}")
test_str = ("Is there any validation in javascript or ruby on rails to allow user registration via corporate email\n\n"
"for example of corporate email:- \n"
"1) jai@jai.com where jai is domain name \n"
"2) ajay@google.com where google.com is domain name\n"
"and not allow other email service email\n\n"
"example :-\n"
"1) jai@gmail.com\n"
"2) jai@hotmail.com\n"
"3) jai@yahoo.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")