using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+|(?<!\s)(?=-)";
string substitution = @"\n";
string input = @"19 20 22 -1 -3-4-10 -7 2 10";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}