use strict;
my $str = '19 20 22 -1 -3-4-10 -7 2 10';
my $regex = qr~\s+|(?<!\s)(?=-)~mp;
my $subst = '\\n';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";