const regex = new RegExp('\\s+|(?<!\\s)(?=-)', 'gm')
const str = `19 20 22 -1 -3-4-10 -7 2 10`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);